Post B6kNynGMjjAowmTLYO by grawity@social.treehouse.systems
(DIR) More posts by grawity@social.treehouse.systems
(DIR) Post #B6kNynGMjjAowmTLYO by grawity@social.treehouse.systems
0 likes, 0 repeats
Work mail server kept rejecting mail due to rDNS lookup failures, and was logging request timeouts internally... and sure, rDNS + DNSSEC validation = slow, but it seems like the Unbound resolver sometimes just drops queries on the floor? More than once, tcpdump showed me a query arrive at the resolver and nothing go out, not even a servfail error.I assume that *has to be* caused by something trivially tunable, like increasing Unbound's receive UDP buffer size maybe – but I decided to just switch the resolver to BIND instead, and so far it's been running with zero complaints with the default knobs &shrug;(...well, except for having to raise a "max records per type" limit, because a local hosting company does their SPF by pointing "a:" to a subdomain which has 190 A records listing every individual IP address of theirs, instead of doing "ip4:<cidr>" like a normal)
(DIR) Post #B6kNynVbp3Mni3bWJU by domi@donotsta.re
0 likes, 0 repeats
@grawity if i recall correctly @ar mentioned something similar happening with bgpwtf’s unbound deployment. i don’t know the specifics tho
(DIR) Post #B6kPiT8jz9pvoOFWWu by ar@is-a.cat
0 likes, 0 repeats
@domi @grawity issue on our end was caused by a specific IP address not getting set on the lo interface (silly routing shenanigans). doesn't sound related to what's described here.
(DIR) Post #B6kPiTKnGLTgPlt9Jg by domi@donotsta.re
0 likes, 0 repeats
@ar @grawity ah, mb