Subject: [9fans] Breaking up long lines in sam into more manageable ones

From: [email-masked]
Date: Wed, 25 Aug 2021 14:20:41 -0400

I would like to be able to break up long lines in sam in a way similar to the way I break them up in ed. For ed, I rely on the external command !fold -s -w80 %.

This did not work for me in sam. What would be the best way to achieve this in sam? And is there a format line(s) command I could use? 

Many thanks. 
------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8df760861ae2c8cd-M1c04b967118bc3df845c887a
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: "David Leimbach via 9fans" <[email-masked]>
Date: Wed, 25 Aug 2021 08:31:31 -1000

Try in the tagline 
Edit ,|fold -s -w80
Highlight it and middle click it.

Sent from my iPad

> On Aug 25, 2021, at 8:20 AM, [email-masked] wrote:
> 
> 
> 9fans / 9fans / see discussions + participants + delivery options Permalink

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8df760861ae2c8cd-M61bada46ff3aab1a9434e6b5
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: Humm <[email-masked]>
Date: Wed, 25 Aug 2021 20:49:52 +0200

> I would like to be able to break up long lines in sam in a way 
> similar to the way I break them up in ed. For ed, I rely on the 
> external command !fold -s -w80 %.
>
> This did not work for me in sam. What would be the best way to 
> achieve this in sam? And is there a format line(s) command I could 
> use? 
        | Plan 9-command
               Send the range to the standard input, and replace it by 
               the standard output, of the Plan 9 command.

Thus, run something like `,|fold -s` or `,|fmt` to format long lines 
in, for example, your emails.

-- 
Humm

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8df760861ae2c8cd-M93188a3c4a4e50f7988df1b7
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: "fwrm via 9fans" <[email-masked]>
Date: Thu, 26 Aug 2021 18:01:30 -0400

> Highlight it and middle click it.

Yeah but that's acme not sam.

You can do: ,|your_cmd
------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8df760861ae2c8cd-M59f260c07265cbbe30e9c897
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: "David Leimbach via 9fans" <[email-masked]>
Date: Thu, 26 Aug 2021 12:47:40 -1000

Sent from my iPad

> On Aug 26, 2021, at 12:01 PM, fwrm via 9fans <[email-masked]> wrote:
> 
> 

Oh yeah! Sorry….

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8df760861ae2c8cd-M7bea4a61bbec9c44457d0721
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: [email-masked]
Date: Fri, 27 Aug 2021 04:55:25 -0400

Thank you so much for these answers. I greatly appreciate it. 
------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T8df760861ae2c8cd-M7b0cae6b9565025cd21584fa
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription