Subject: [9fans] git/{diff,import}: make it easier to handle manually-asembled patch emails

From: [email-masked]
Date: Sun, 22 Aug 2021 13:10:08 -0400

Often, people (including myself) will write emails that
can almost be applied with git/import.  This changes
git/diff and git/import so that things will generally
work even when assembling diffs by hand:

1.      git/import becomes slightly more lax:

                ^diff ...
                ^--- ...

        will both be detected as the start of a patch.

2.  git/diff produces the same format of diff
        as git/export, starting with paths:

                --- a/path/to/file
                +++     b/path/to/file

        which means that the 'ape/patch -p1' used
        within git/import will just work.

So with this, if you send an email to the mailing list,
write up a committable description, and append the
output of git/diff to the end of the email, git/import
should just work.

[this patch was send through the mailing list using the
above procedure, and will be committed with git/import
to verify that it works as advertised]

diff 8c228a123fa0c6062570964011854302bbf57242 uncommitted
--- a/sys/src/cmd/git/diff
+++ b/sys/src/cmd/git/diff
@@ -26,12 +26,16 @@
                git/query -c $commit HEAD | subst '^..'
 }
 
+mntgen /mnt/scratch
+bind $branch/tree/ /mnt/scratch/a
+bind . /mnt/scratch/b
+echo diff `{git/query $commit} uncommitted
 for(f in `$nl{lsdirty | sort | uniq}){
-       orig=$branch/tree/$f
-       if(! test -f $orig)
+       cd /mnt/scratch
+       if(! test -f a/$f)
                orig=/dev/null
-       if(! test -f $f)
+       if(! test -f b/$f)
                f=/dev/null
-       diff -u $orig $f
+       diff -u a/$f b/$f
 }
 exit ''
--- a/sys/src/cmd/git/import
+++ b/sys/src/cmd/git/import
@@ -45,7 +45,7 @@
                state="body"
                next
        }
-       (state=="headers" || state=="body") && (/^diff/ || /^---[       ]*$/){
+       (state=="headers" || state=="body") && (/^diff / || /^--- /){
                state="diff"
        }
        state=="body" {

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T403f90e3b0509704-Md1cc4902bb399c16511e2f9b
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: [email-masked]
Date: Sun, 22 Aug 2021 13:12:11 -0400

Oops, sent to the wrong mailing list -- sorry about the noise.

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T403f90e3b0509704-M300dfe7499e5b62ca9db9bbf
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription

---

From: [email-masked]
Date: Sun, 22 Aug 2021 13:19:29 -0400

> Oops, sent to the wrong mailing list -- sorry about the noise.

Also, as a side note, it seems like the 9fans
mailing lists mangles patches -- if anyone
ever sends patches, they'll need to be sent
as attachments.

------------------------------------------
9fans: 9fans
Permalink: https://9fans.topicbox.com/groups/9fans/T403f90e3b0509704-M61320344b346fd78f92b2b62
Delivery options: https://9fans.topicbox.com/groups/9fans/subscription