Subject: [9front] plan9.ini fs= should accept full dial strings

From: [email-masked]
Date: Wed, 25 Aug 2021 23:36:29 -0400

let's say we want to do both serve a full file system
to certain clients *and* serve a specially constructed
namespace to generic clients trying to 9fs us on the
standard port.

currently, plan9.ini fs= value must be just an ip
address or host name. the system translates it
internally to tcp![ip]!564.

why can't fs= be any valid dial string?

sl

---

From: james palmer <[email-masked]>
Date: Thu, 26 Aug 2021 12:31:37 +0100

> why can't fs= be any valid dial string?

seems to be because the port depends onthe value of bootargs.

tcp boot is on 564 and tls boot is 17020.

to keep compatibility with existing plan9.ini files the fs variable would need to be parsed to see if a port has been specified.

another option might be to treat bootargs as a dialstring (similar to how local filesystems are handled) like so:

bootargs=local!/dev/sdE0/fs -> local hjfs
bootargs=tls!192.168.0.2 -> tls to the 192.168.0.2 file server
bootargs=tcp!biobuf.link!555 -> tcp boot to a remote file server on a non standard port

- james