"Error while linking" in Ubuntu lazarus / 32-Linux ---------------------------------------------------------------------- Edson · 2018-07-13 23:42 Hi just installed FPC/Lazarus in a virtual Ubuntu 15. Installed using *.deb from https://www.lazarus-ide.org/ Now when compiling an empty project, have the error: /usr/bin/ld: /usr/lib/fpc/3.0.4/units/x86_64-linux/rtl/cprt0.o: unrecognized relocation (0x2a) in section `.text' ---------------------------------------------------------------------- Phil · 2018-07-14 00:06 Quote from: Edson on July 14, 2018, 01:42:10 amNow when compiling an empty project, have the error: I see this: http://free-pascal-general.1045716.n5.nabble.com/Linker-error- td5723410.html ---------------------------------------------------------------------- VTwin · 2018-07-14 00:28 This may not be helpful, but I have multiple installations of Lazarus 1.8.4 on Ubuntu 16 installed in VirtualBox from deb files that run fine. I don't have any information on your error messages however. I install the following:   fpc_3.0.4-2_amd64.deb   fpc-src_3.0.4-2_amd64.deb   lazarus-project_1.8.4-0_amd64.deb It has worked well for me. Cheers, VTwin EDIT: I assume Ubuntu 64 bit? ---------------------------------------------------------------------- Edson · 2018-07-14 00:48 Quote from: Phil on July 14, 2018, 02:06:59 amI see this: http://free-pascal-general.1045716.n5.nabble.com/Linker-error- td5723410.html Thanks Phill. I've saw this before but doen't help me. Quote from: VTwin on July 14, 2018, 02:28:11 amI have multiple installations of Lazarus 1.8.4 on Ubuntu 16 installed in VirtualBox from deb files that run fine. I don't have any information on your error messages however. I install the following:   fpc_3.0.4-2_amd64.deb   fpc-src_3.0.4-2_amd64.deb   lazarus-project_1.8.4-0_amd64.deb It has worked well for me. I've installed the same *.deb but not working.  Yes I've Ubuntu 64 bits, but the version 15. What version of gcc you have? I've upgraded to gcc 5, but get the same error. ---------------------------------------------------------------------- VTwin · 2018-07-14 01:38 It looks like 7.11.1. I made no changes from the default installation. EDIT: You said gcc, not gdb, I'm confused. I could be wrong , but I don't think gcc has any significance here. ---------------------------------------------------------------------- Martin_fr · 2018-07-14 01:48 Afaik (reading the linked description) you need to update "ld" -> according to the link, that is binutils ---------------------------------------------------------------------- Edson · 2018-07-14 03:05 Quote from: Martin_fr on July 14, 2018, 03:48:39 amAfaik (reading the linked description) you need to update "ld" -> according to the link, that is binutils Hi Martin. I'm triying to update binutils to 2.30, but my Ubuntu says I need libc6 >= 2.27, and I have 2.21. Then when I try to update "libc6", it says "break existing package libc-bin dependency < 2.22". EDIT: Even when trying isntall binutils 2.26 (I have 2.25) with: Quotesudo apt-get install binutils-2.26 I get: QuoteReading package lists... Done Building dependency tree      Reading state information... Done E: Unable to locate package binutils-2.26 E: Couldn't find any package by regex 'binutils-2.26' ---------------------------------------------------------------------- Handoko · 2018-07-14 06:13 Quote from: Edson on July 14, 2018, 01:42:10 amjust installed FPC/Lazarus in a virtual Ubuntu 15. Maybe you can consider to use newer versions of Ubuntu. Ubuntu 15 is not a LTS (long-term support) release, its support has expired on July 2016. You will be difficult to upgrade certain packages when using unsupported version. Current stable version of Ubuntu is 18.04 LTS. I checked binutils package for Ubuntu, none of them is available for Ubuntu 15: https://packages.ubuntu.com/search?keywords=binutils ---------------------------------------------------------------------- Edson · 2018-07-14 16:01 Quote from: Handoko on July 14, 2018, 08:13:44 amQuote from: Edson on July 14, 2018, 01:42:10 amjust installed FPC/Lazarus in a virtual Ubuntu 15. Maybe you can consider to use newer versions of Ubuntu. Ubuntu 15 is not a LTS (long-term support) release, its support has expired on July 2016. You will be difficult to upgrade certain packages when using unsupported version. Current stable version of Ubuntu is 18.04 LTS. I checked binutils package for Ubuntu, none of them is available for Ubuntu 15: https://packages.ubuntu.com/search?keywords=binutils OK. I will update to a newer version.