samba-vscan FAQ
***************

Q: Does samba-vscan send out notification messages if access to an infected
   file is denied?
A: No, samba-vscan just denies the access and logs it via the syslog facility.
   But tools like Logcheck (www.psionic.com) or snort (www.snort.org)
   can be used to generate alerts/notification messages. You may
   change SYSLOG_FACILITY and SYSLOG_PRIORITY, used for normal messages, and
   SYSLOG_PRIORITY_ALERT for virus messages (see vscan-<product>.h)
   to fit your needs.

Q: What happens with infected files?
A: Currently nothing, the access to those files is denied. SAVI can be
   configured to clean files automatically, but I dislike such a feature.
   Moving those files into a quarantine directory has been added to TODO.

Q: Huh? I can store an infected file onto a protected share?
A: Yes, currently a virus scan is only performed if a file is opened
   for reading _from_ a  Samba share, but not if a file is written _to_ a 
   share! So, currently it's possible to store an infected file onto a share
   but any later access should be denied. A later release of samba-vscan
   will problably perform a virus scan, if a file is copied to a share
   (well, when "close" is called after the file transfer) and move it then
   to a quarantine directory (see above).

Q: Using vscan-samba slows down using file shares / connecting to new
   shares. Why?
A: Win* uses only one connection for all shares you're connected to. 
   Therefore a smbd client is forked only once and only one instance of
   samba-vscan module is created. So, if scanning of a large file takes
   some time, this process will slow down all shares. See
   http://marc.theaimsgroup.com/?t=100629451400005&w=2&r=1 for details.
   I currently have no clue how to avoid this problem :-(

Q: Using this module I can't access any file containing german
   umlauts or special characters. Why?
A: When using samba-vscan unicode support seems to be broken. I'm currently
   not sure if the provided VFS patch break it or if unicode support
   is broken within the VFS layer in general. 
   See http://marc.theaimsgroup.com/?t=100662550000001&w=2&r=1 or
   http://marc.theaimsgroup.com/?l=samba-technical&m=100681100607866&w=2
   for details. I'm not sure, if this is still valid in  recent Samba 
   releases, i.e. 2.2.6 (as the time of this writing).
  
