next - previous - toc

2.2. Menu

Data

Data -> New
Create new zero length data.

Data -> Open File
Open file and display data using defaultTemplate

Data -> Open Socket
Listen to socket and display incoming data

Data -> Save File

Data -> Save File As

Data -> Write To Socket
Write selected data to previously opened socket

Data -> Close
Close the currently selected project

Data -> Exit
Close all projects and exit. Save workbench.xml and options.xml

Project

Project -> Open Template

Project -> Save Template

Project -> Save Template As

Project -> New Structure

Project -> Open Structure

Project -> Save Structure

Project -> Save Structure As

Project -> Rerender
Complete rerendering of the selected structure.

Edit

Edit -> Define Find And Replace

Here you can define the search and find data used by the find and replace actions. Granularity defines the number of bits skipped if the search was successful or unsucessful.

Edit -> Find Next
Search forward for starting at the current offset.

Edit -> Find Previous
Search backwards starting at the current offset.

Edit -> Find All
Search current data selection and display results.

Edit -> Replace
If the current data selection equals search data replace it with replace data.

Edit -> Replace All
Search current data selection and replace all.

Tools

Tools -> Diff Data

Find differences between data in selected project and other projects or DataClipboard. The selection in both data sources must be the same size.
Example: The data in the project data.class from offset 12-58 is diffed against the clipboard. The differences are displayed in hex bytes.

Tools -> DataClipboard
Displays the content of the DataClipboard.

Options

Options -> Editor

Options -> DataView


next - previous - toc