# This is a shell archive. Save it in a file, remove anything before # this line, and then unpack it by entering "sh file". Note, it may # create directories; files and directories will be owned by you and # have default permissions. # # This archive contains: # # DESCR # Makefile # PLIST # distinfo # echo x - DESCR sed 's/^X//' >DESCR << 'END-of-DESCR' XHost is a very powerful DNS query and testing command-line tool. X XMajor differences with the ancient version of the program with the same Xname that's included in the BIND-4 and BIND-8 distributions: X X - Major overhaul of the entire code. X - Very rigid error checking, with more verbose error messages. X - Zone listing section completely rewritten. X - It is now possible to do recursive listings into delegated zones. X - Maintain resource record statistics during zone listings. X - Maintain count of hosts during zone listings. X - Check for various extraneous conditions during zone listings. X - Check for illegal domain names containing invalid characters. X - Verify that certain domain names represent canonical host names. X - Perform ttl consistency checking during zone listings. X - Exploit multiple server addresses if available. X - Option to exploit only primary server for zone transfers. X - Option to exclude info from names that do not reside in a zone. X - Implement timeout handling during connect and read. X - Write resource record output to optional log file. X - Special MB tracing by recursively expanding MR and MG records. X - Special mode to check SOA records at each nameserver for a zone. X - Special mode to check reverse mappings of host addresses. X - Extended syntax allows multiple arguments on command line or stdin. X - Configurable default options in HOST_DEFAULTS environment variable. X - Implement new resource record types from RFC 1183 and 1348. X - Basic experimental NSAP support as defined in RFC 1637. X - Implement new resource record types from RFC 1664 and 1712. X - Implement new resource record types from RFC 1876 and 1886. X - Code is extensively documented. END-of-DESCR echo x - Makefile sed 's/^X//' >Makefile << 'END-of-Makefile' X# $NetBSD: Makefile,v 1.3 2003/03/29 12:41:56 jmmv Exp $ X XDISTNAME= host-20030405 XCATEGORIES= net XMASTER_SITES= ftp://ftp.weird.com/pub/local/ X XMAINTAINER= packages@netbsd.org XHOMEPAGE= http://www.weird.com/~woods/host.html XCOMMENT= powerful DNS query and testing tool X X.include "../../mk/bsd.prefs.mk" X XNO_CONFIGURE= yes X XMAKEFILE= Makefile.BSD X XMAKE_FLAGS+= __NetBSD__=1 X X# This removes "nslookup" from the value given in the distributed Makefile.BSD X# XMAKE_FLAGS+= SCRIPTS="nscheck mxlookup rblookup" X X# this works around a bug in the distributed Makefile.BSD X# (FILES should never have been defined in it) X# XMAKE_FLAGS+= FILES= X X.include "../../mk/bsd.pkg.mk" END-of-Makefile echo x - PLIST sed 's/^X//' >PLIST << 'END-of-PLIST' X@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:55:36 zuntum Exp $ Xbin/host Xbin/mxlookup Xbin/nscheck Xbin/rblookup Xman/man1/host.1 END-of-PLIST echo x - distinfo sed 's/^X//' >distinfo << 'END-of-distinfo' X$NetBSD: distinfo,v 1.2 2001/04/21 11:23:17 wiz Exp $ X XSHA1 (host-20030405.tar.gz) = 3c18dce6b65c9454a89e4ca9d5a164bd45817396 XSize (host-20030405.tar.gz) = 141258 bytes END-of-distinfo exit .